POJ-2955 区间DP

版权声明:本文为博主原创文章,若需要引用、转载,只需注明来源及原文链接,若有错误,欢迎纠正。 https://blog.csdn.net/u014137295/article/details/87890476

Description
We give the following inductive definition of a “regular brackets” sequence:
the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6
解题思路:
边界dp[i][i]=0;
if(s[i]与s[k]是匹配的)
dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);(将i到j分成[xxx]xxx两部分)
else dp[i][j]=dp[i+1][j];(去掉第一个元素)
代码:

#include<iostream>
using namespace std;
int main(){
	string s;
	while(cin>>s,s[0]!='e'){
		int len=s.size(),dp[101][101]={0};
		for(int l=2;l<=len;++l)
			for(int i=0;i+l-1<len;++i){
				int j=i+l-1;
				dp[i][j]=dp[i+1][j];
				for(int k=i+1;k<=j;++k)
					if((s[i]=='('&&s[k]==')')||(s[i]=='['&&s[k]==']'))
						dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
			}
		cout<<dp[0][len-1]<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/u014137295/article/details/87890476
今日推荐