HDU - 2955 Robberies(背包dp)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29605    Accepted Submission(s): 10829


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
 
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
 
  
2 4 6
 

Source

IDI Open 2009

             这道题最容易错的地方就是自以为可能性就只有小数点后两位,然后乘个100取整来做背包~~其实数据输入是小数点后好多位的,这样做只能是wa~~

              这道题正确的方法是将ma[k],表示为你取得的价格为k时最安全的概率是多少~~然后这样的话,我们就能够得到状态转移方程:

              ma[k]=max(ma[k] , ma[k-v[s] ]*(1-im[s]));

              其中s表示的是进行第s个银行的规划。

             而其中k的上限便是所有银行的钱的总和了~~。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
double ma[10005];
int v[105];
double im[105];
int main()
{
    int te;
    cin>>te;
    while(te--)
    {
        memset(ma,0,sizeof(ma));
        double m;
        int n;
        int sum=0;
        scanf("%lf%d",&m,&n);
        for(int s=1;s<=n;s++)
        {
            scanf("%d %lf",&v[s],&im[s]);
            sum+=v[s];
        }
        ma[0]=1;
        for(int s=1;s<=n;s++)
        {
            for(int k=sum;k>=v[s];k--)
            {
                if(ma[k]<ma[k-v[s]]*(1-im[s]))
                {
                    ma[k]=ma[k-v[s]]*(1-im[s]);
                }
            }
        }
        for(int s=sum;s>=0;s--)
        {
            if(ma[s]>1-m)
            {
                cout<<s<<endl;
                break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/80464106