HDU-2044-一只小蜜蜂...(水)

一只小蜜蜂...




Problem Description

有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。

 

Input

输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
 

Output

对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
 

Sample Input

 
  
2
1 2
3 6
 

Sample Output

 
  
1
3
#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long int a[60];
    a[0]=1;
    a[1]=1;
    for(int i=2;i<59;i++)
    {
        a[i]=a[i-1]+a[i-2];
    }
    int n,c,d;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&c,&d);
        printf("%lld\n",a[d-c]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38620461/article/details/79960539