HDU - 2044 一只小蜜蜂... 【递推】

Description

有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。

Input

输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。

Output

对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。

Sample Input

2
1 2
3 6

Sample Output

1
3
#include <iostream>
#include <cstdio>

using namespace std;

long long a[55];

int main()
{
    int n, m, t;
    a[0] = 0;
    a[1] = 1;
    a[2] = 2;
    for (int i = 3; i < 53; i++)
    {
        a[i] = a[i-1] + a[i-2];
    }
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d %d", &n, &m);
        printf("%lld\n", a[m-n]);
    }

    return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105336222
今日推荐