HDU1213 How Many Tables (求小团体的个数)

题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=1213

题目

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

题意

求小团体的个数。每个小团体的人都直接或间接认识。

分析

初始化小团体个数sum为总人数。
根据M对关系:(x,y),如果x与y不在一个小团体中,合并并sun–。
最后sun即为所求。

AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn=1e3+100;
int par[maxn];
int sum,N,M;
void init()
{
    for(int i=0;i<=N;i++) par[i]=i;
    sum=N;
}
int find(int x)
{
    return par[x]==x?x:par[x]=find(par[x]);
}
void unit(int x,int y)
{
    par[find(x)]=find(y);
}
bool same(int x,int y)
{
    return find(x)==find(y);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&N,&M);
        init();
        while(M--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(!same(x,y))
            {
                sum--;
                unit(x,y);
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37685156/article/details/80560128