[最小生成树] 畅通工程再续 HDU图论03 1003

畅通工程再续

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output

1414.2
oh!

Author

8600

Source

2008浙大研究生复试热身赛(2)——全真模拟



#include <bits/stdc++.h>
using namespace std;

const int mc = 110;
const int mm = mc * mc;
int p[mc];
int x[mc], y[mc];

struct node 
{
	int x, y;
	double z;
} e[mm];
bool cmp(const node& a, const node& b)
{
	return a.z < b.z;
}

int par(int x)
{
	if (p[x] == x)
		return x;
	return p[x] = par(p[x]);
}

int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int c;
		scanf("%d", &c);
		
		for (int i = 1; i <= c; i++)
			scanf("%d %d", &x[i], &y[i]);
			
		int edge = 1;
		for (int i = 1; i <= c; i++)
		{
			for (int j = 1; j <= c; j++)
			{
				if ( i != j)
				{
					double dis = sqrt(abs(x[i]-x[j]) * abs(x[i]-x[j]) 
									+ abs(y[i]-y[j]) * abs(y[i]-y[j]));
					if (dis >= 10 && dis <= 1000)
					{
						e[edge].x = i;
						e[edge].y = j;
						e[edge].z = dis;
						edge ++;
					}
				}
			}
		}
		
		edge--;
		if (edge < c - 1)
		{
			printf("oh!\n");
			continue;
		}
		
		sort(e + 1, e + edge + 1, cmp);
		
		for (int i = 1; i <= c; i++)
			p[i] = i;
		
		int sum = 0;
		double ans = 0;
		for (int i = 1; ; i++)
		{
			if (sum == c - 1)
				break;
			int px = par(e[i].x);
			int py = par(e[i].y);
			if (px != py)
			{
				p[px] = py;
				ans += e[i].z * 100;
				sum++;
			}
		}
		
		printf("%.1f\n", ans);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/80756082
今日推荐