畅通工程再续 HDU - 1875 最小生成树

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。 
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。 
Output每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
Sample Output
1414.2

oh!

用并查集来判断是否全部联通,用克鲁斯卡尔来求最小生成树,模板题吧

#include <algorithm>  
#include <iostream>   
#include <cstring>  
#include <iomanip>  
#include <string>  
#include <vector>  
#include <cstdio>  
#include <queue>  
#include <stack>  
#include <cmath>  
#include <map>  
#include <set>  
#define INF 0x3f3f3f3f
const int maxn = 20000;   
using namespace std;  
struct land
{
	int x,y;
}arr[maxn];    //存边 
struct node
{
	int u,v;
	double w;	
}edge[maxn];    //存序号,注意分开存的 
int pre[maxn],tot,cnt,flag,n;
double sum;
void init()
{
	for(int i=1;i<=n;i++)
	{
		pre[i]=i;
	}
	cnt=flag=sum=tot=0;
}
int find(int x)
{
	if(x==pre[x]) return x;  
    return pre[x]=find(pre[x]);
}
int merge(int x,int y)
{
	int xx=find(x);
	int yy=find(y);
	if(xx!=yy)
	{
		pre[yy]=xx;
		return 1;
	}
	else
	{
		return 0;
	}
}
bool cmp(node a,node b)
{
	return a.w<b.w;
}
void kru()
{
	sort(edge,edge+tot,cmp);
	for(int i=0;i<tot;i++)
	{
		if(edge[i].w<=1000&&edge[i].w>=10&&merge(edge[i].u,edge[i].v))
		{
			sum+=edge[i].w;
		}
	}
	for(int i=1;i<=n;i++)
	{
		if(i==pre[i])
		{
			cnt++;
		}
		if(cnt>1)   //代表有结点没有连接上或者说是没有全部联通 
		{
			flag=1;
			break;
		}
	}
	if(flag==1)
	{
		printf("oh!\n");
		return ;
	}
	else
	{
		printf("%.1lf\n",sum*100);
	}
}
int main()
{  
	//freopen("C:/input.txt", "r", stdin);
    int T;
	double x,y;  
    scanf("%d",&T);  
    while(T--)
	{  
		scanf("%d",&n);
		init();
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&arr[i].x,&arr[i].y);	
		} 
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				edge[tot].u=i;
				edge[tot].v=j;
				x=(arr[j].y-arr[i].y)*(arr[j].y-arr[i].y);  
                y=(arr[j].x-arr[i].x)*(arr[j].x-arr[i].x);  
                double temp=sqrt(x+y); 
				edge[tot++].w=temp;
			}
		}
		kru();
    }  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/evildoer_llc/article/details/80428626