A - Mathematically Hard LightOJ - 1007

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.


Input

Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237

Note

Euler's totient function  applied to a positive integer n is defined to be the number of positive integers less than or equal to n that are relatively prime to n is read "phi of n."

Given the general prime factorization of , one can compute  using the formula

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define lowbit(x) (x&(-x))
using namespace std;

typedef unsigned long long ll;

const int maxn=5e6+10;
ll phi[maxn];
/*
我感觉这道题就是在考察我是不是知道llu,讲真,我都想放弃了
还有就是0和1是互质的,因为0的约数有无数个,但是1的约数只有1,两个数的最大公约数是1,所以互质
*/

void init(){
    memset(phi,0,sizeof(phi));
    phi[1]=1;
    for(int i=2;i<maxn;i++){
        if(!phi[i]){
            for(int j=i;j<maxn;j+=i){
                if(!phi[j])phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
        }
    }
    for(int i=1;i<maxn;i++){
        phi[i]=phi[i-1]+phi[i]*phi[i];
    }
}

int main(){
    init();
	int T,kase=1;
	scanf("%d",&T);
	while(T--){
        int l,r;
        scanf("%d %d",&l,&r);
        printf("Case %d: %llu\n",kase++,phi[r]-phi[l-1]);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/80228591