lightoj1007线筛求欧拉函数

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input

Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237

Note

Euler's totient function  applied to a positive integer n is defined to be the number of positive integers less than or equal to n that are relatively prime to n is read "phi of n."

Given the general prime factorization of , one can compute  using the formula

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define maxn 5000005

using namespace std;
int p[maxn];
unsigned long long phi[maxn];
int cnt;
int t;
void euler()
{
    memset(phi,0,sizeof(phi));
    memset(p,0,sizeof(p));
    cnt=0;
    for(int i=2;i<maxn;i++)
    {
        if(!phi[i])
        {
            phi[i]=i-1;
            p[cnt++]=i;
        }
        for(int j=0;j<cnt&&i*p[j]<maxn;j++)
        {
            if(i%p[j])
                phi[i*p[j]]=phi[i]*phi[p[j]];
            else
            {phi[i*p[j]]=phi[i]*p[j];
            break;
        }
    }
}
phi[0]=0;
for(int i=1;i<maxn;i++)
    phi[i]=phi[i-1]+phi[i]*phi[i];

}
int main()
{
    scanf("%d",&t);
    int w=0;
    euler();
    while(t--)
    {
        w++;
        int a,b;
        scanf("%d%d",&a,&b);
        printf("Case %d: %llu\n",w,phi[b]-phi[a-1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89810916