1041 Be Unique (20 point(s)) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/101866453

1041 Be Unique (20 point(s))

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤ 105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input:

7 5 31 5 88 67 88 17

Sample Output:

31

题目大意:

输入 N 个数字,按顺序读入,寻找第一个仅出现一次的数字,输出;若没有,则输出 None

设计思路:

两个数组,一个按顺序储存数字,另一个利用索引值储存对应数字的出现次数,再按顺序遍历一遍查找第一个仅出现一次的数字

编译器:C (gcc)
#include <stdio.h>

int main(void)
{
        int num[100001] = {0}, c[100001] = {0};
        int n;
        int i;

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%d", &num[i]);
                c[num[i]]++;
        }
        for (i = 0; i < n; i++) {
                if (c[num[i]] == 1) {
                        printf("%d", num[i]);
                        return 0;
                }
        }
        if (i >= n) {
                printf("None");
        }

        return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/101866453