HDU 2025 查找最大元素

http://acm.hdu.edu.cn/showproblem.php?pid=2025

Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
 
Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
 
Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
 
Sample Input
abcdefgfedcba
xxxxx
 
Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)
 
代码:
#include <bits/stdc++.h>

using namespace std;

char s[111];
int main()
{
    while(scanf("%s",s)!=EOF)
    {
        int len = strlen(s);
        int max=s[0];
        for(int i=0; i<len; i++)
        {
            if(s[i]>=max)
                max=s[i];
        }
        for(int i=0; i<len; i++)
        {
            if(s[i]==max)
                printf("%c(max)",s[i]);
            else
                printf("%c",s[i]);
        }
        cout<<endl;
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9221832.html