杭电2025——查找最大值C++版

Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。

Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。

Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。

Sample Input
abcdefgfedcba
xxxxx

Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

Author
lcy

Source
C语言程序设计练习(四)

#include<iostream>
#include<cstring> 
using namespace std;
void f(char a[])
{
    int i,l;
    char b='a';
    l=strlen(a);
    for(i=0;i<l;i++)
    {
        if(a[i]>b)
        {
            b=a[i];
        }
    }
    for(i=0;i<l;i++)
    {
        cout<<a[i];
        if(a[i]==b)
        {
           cout<<"(max)";
        }
    }
}
int main()
{
    char a[100];
    while(cin>>a)
    {
        f(a);
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43289087/article/details/88645245
今日推荐