hdu2025——查找最大元素

对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入”(max)”。
Sample Input
abcdefgfedcba
xxxxx
Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int MAXN=150;
char s[MAXN];
int main(void){
    while(~scanf("%s",s)){
        char m=s[0];
        int n=strlen(s);
        for(int i=1;i<n;i++){
            if(s[i]>m){
                m=s[i];
            }
        }
        for(int i=0;i<n;i++){
            printf("%c",s[i]);
            if(s[i]==m){
                printf("(max)");
            }
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/westbrook1998/article/details/80436096