查找最大元素

Problem Description

对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。

Input

输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。

Output

对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。

Sample Input

 

abcdefgfedcba xxxxx

Sample Output

 

abcdefg(max)fedcba x(max)x(max)x(max)x(max)x(max)

 

 

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    char a[100],max1;
    int flag;
    while(~scanf("%s",a))
    {
        max1=a[0];
        flag=strlen(a);
        for(int i=1; i<flag; i++)
            if(a[i]>max1)
                max1=a[i];
        for(int i=0; i<flag; i++)
        {
            if(a[i]==max1)
                cout<<a[i]<<"(max)";
            else cout<<a[i];
        }
        cout<<endl;
    }
    return 0;
}

题解:      思路还可以想到,开始我写这道题的时候找最大值的时候找错了,if里边条件写错了,后来改了一下,

猜你喜欢

转载自blog.csdn.net/shaodongyue/article/details/80499984