问题 1232: 查找最大元素

/*题目描述
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。

输入
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母及数字构成

输出
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。

样例输入
abcdefgfedcba
xxxxx
样例输出
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)/
import java.util.
;

public class Text_1232 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
String s = sc.nextLine();
System.out.println(result(s));
}
}

public static String result(String s) {
	char max = s.charAt(0);
	int i;
	for (i = 1; i < s.length(); i++) {
		if (max < s.charAt(i)) {
			max = s.charAt(i);
		}
	}
	String result = "";
	for (int j = 0; j < s.length(); j++) {
		if (max > s.charAt(j)) {
			result = result + s.charAt(j);
		} else if (max == s.charAt(j)) {
			result = result + s.charAt(j) + "(max)";
		} else {
			result = result + s.charAt(j);
		}
	}
	return result;
}

}

猜你喜欢

转载自blog.csdn.net/cwj_ya/article/details/82823600