1137: 查找最大元素 C语言

1137: 查找最大元素
时间限制: 1 Sec 内存限制: 128 MB
提交: 6813 解决: 4919
[状态] [讨论版] [提交] [命题人:admin]
题目描述
对于输入的字符串,查找其中的ASCII码值最大字母,在该字母后面插入字符串“(max)”。
输入
输入一行长度不超过200的字符串组成,字符串仅由大小写字母构成。
输出
输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
样例输入 Copy
abcdefgfedcbag
样例输出 Copy
abcdefg(max)fedcbag(max)

#include <stdio.h>
#include <string.h>


// 查找最大元素 
int main() {
    
    
	char max, ch[200];
	int i, n;
	// 输入字符串 
	gets(ch);
	
	n = strlen(ch);
	max = ch[0];
	for(i = 0; i < n; i++){
    
    
		// 查找最大元素 
		if(ch[i] > max){
    
    
			max = ch[i];
		}
	}
	
	for(i = 0; i < n; i++){
    
    
		printf("%c", ch[i]);
		if(ch[i] == max)
			printf("(max)");
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_45306379/article/details/121513025