c 语言 查找最大元素

/*****
题目描述
对于输入的字符串,查找其中的ASCII码值最大字母,在该字母后面插入字符串“(max)”。
输入
输入一行长度不超过200的字符串组成,字符串仅由大小写字母构成。
输出
输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
样例输入 Copy
abcdefgfedcbag
样例输出 Copy
abcdefg(max)fedcbag(max)
*****/
!!!!!本文主要思路来源于[青梅煮茶] (https://blog.csdn.net/zzuli_acmer/article/details/78626541)

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    char str[1000];
    gets(str);char max;max = str[0];
    int i;
    for (i = 0 ;str[i] != '\0';i++)
    {
        if (str[i] > max)
        max = str[i];
    }
    for (i = 0 ;str[i] != '\0' ;i++)
    {
        if(str[i] == max)
        printf("%c(max)",str[i]);
        else
        printf("%c",str[i]);
    }
    return 0;
}

发布了84 篇原创文章 · 获赞 0 · 访问量 1818

猜你喜欢

转载自blog.csdn.net/qq_39345244/article/details/104881396