【水】HDU2025查找最大元素

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)
[显示标签]
Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
Sample Input

abcdefgfedcba
xxxxx

Sample Output

abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

Hint
lcy
Source
  C语言程序设计练习(四)  
Related problem
2024 2032 2027 2023 2028

有个小窍门是,你不必非得将“(max)”插入数组里面,只要在输出时控制就可以了。所以首先可以先遍历数组寻找最大的字母,如何存起来,输出时控制一下就好了。

代码如下:

#include <iostream>
#include <string>
using namespace std;
int main()
{
string s;
while(cin>>s)
{
    char max=s[0];
    for(int i=1;i<s.size();i++)
    {
     if(s[i]>max)
        max=s[i];
    }
    for(int i=0;i<s.size();i++)
    {    
        cout<<s[i];
        if(s[i]==max)
            cout<<"(max)";
     }
    cout<<endl;
}
}

猜你喜欢

转载自blog.csdn.net/qq_41627235/article/details/82805811