查找最大元素(HDU2025)

查找最大元素

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45218    Accepted Submission(s): 24471


Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
 

Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
 

Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
 

Sample Input
 
  
abcdefgfedcba xxxxx
 

Sample Output
 
  
abcdefg(max)fedcba x(max)x(max)x(max)x(max)x(max)
 

#include<stdio.h>
#include<string.h>
int main()
{
char a[100];
while(scanf("%s",&a)!=EOF)
{
char max=0;
int  len=strlen(a);
for(int i=0;i<len;i++)
{
if(max<a[i])
max=a[i];
}
for(int i=0;i<len;i++)
{
printf("%c",a[i]);
if(a[i]==max)
{
printf("(max)");
}
}
printf("\n");
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/heuguangxu/article/details/51104665