03-树1 树的同构(C++)

03-树1 树的同构

给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。
现给定两棵树,请你判断它们是否是同构的。

输入格式
输入给出2棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数N (≤10),即该树的结点数(此时假设结点从0到N−1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。

输出格式
如果两棵树是同构的,输出“Yes”,否则输出“No”。

输入样例1(对应图1)

8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -

输出样例1

Yes

输入样例2(对应图2)

8
B 5 7
F - -
A 0 3
C 6 -
H - -
D - -
G 4 -
E 1 -
8
D 6 -
B 5 -
E - -
H - -
C 0 2
G - 3
F - -
A 1 4

输出样例2

No
# include <iostream>
# include <cstdio>

struct Node {
    
    
	char data;
	int left;
	int right;
};
struct Tree {
    
    
	int n;
	int root;
	Node * treeList;

	Tree(int _n) :n(_n)
	{
    
    
		bool isRoot[15];
		for (int i = 0; i < n; ++i) isRoot[i] = true;

		treeList = new Node[n];
		for (int i = 0; i < n; ++i)
		{
    
    
			char a, b, c;
			scanf("\n%c %c %c", &a, &b, &c);
			treeList[i].data = a;

			if (b == '-') 
				treeList[i].left = -1;
			else 
				treeList[i].left = b - '0', isRoot[treeList[i].left] = false;


			if (c == '-') 
				treeList[i].right = -1;
			else 
				treeList[i].right = c - '0', isRoot[treeList[i].right] = false;
		}

		root = n;
		while (--root >= 0 && !isRoot[root]);
	}
};

bool sameStruct(Tree t1, int r1, Tree t2, int r2)
{
    
    
	if (r1 == -1 && r2 == -1)return true;
	if (r1 == -1 || r2 == -1) return false;
	if (t1.treeList[r1].data != t2.treeList[r2].data) return false;

	return sameStruct(t1, t1.treeList[r1].left, t2, t2.treeList[r2].left) && sameStruct(t1, t1.treeList[r1].right, t2, t2.treeList[r2].right) ||
		sameStruct(t1, t1.treeList[r1].left, t2, t2.treeList[r2].right) && sameStruct(t1, t1.treeList[r1].right, t2, t2.treeList[r2].left);
}

int main(void)
{
    
    
	int n1, n2;
	scanf("%d", &n1);
	Tree t1(n1);

	scanf("%d", &n2);
	Tree t2(n2);

	if (sameStruct(t1, t1.root, t2, t2.root)) printf("Yes\n");
	else printf("No\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45339670/article/details/131985962