03-树3 Tree Traversals Again

03-树3 Tree Traversals Again


An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

30
figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

 Code

# include <iostream>
# include <cstdio>

struct Node {
	int left;
	int right;
};
struct Tree {
	int n;
	int root;
	Node * treeList;
	bool print_tag;
	Tree(int _n) :n(_n)
	{
		int stack[35], top = -1;

		treeList = new Node[n+1];
		for (int i = 0; i <= n; ++i) treeList[i].left = treeList[i].right = -1;

		char s[10];
		int num;
		scanf("%s%d", s, &num);
		int * point = &treeList[num].left;
		stack[++top] = num;
		root = num;

		int k = 2 * n - 1;
		while (k--)
		{
			scanf("%s", s);
			if (s[1] == 'u')
			{
				scanf("%d", &num);
				* point = num;
				stack[++top] = num;
				point = &treeList[num].left;
			}
			else
			{
				int tmp = stack[top--];
				point = &treeList[tmp].right;
			}
		}
		print_tag = false;
	}
	void travPost(int rt)
	{
		if (rt == -1) return;
		travPost(treeList[rt].left);
		travPost(treeList[rt].right);
		printf("%s%d", print_tag ? " " : "", rt);
		print_tag = true;

	}
	
};


int main(void)
{
	int n;
	scanf("%d", &n);
	Tree t(n);


	t.travPost(t.root);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45339670/article/details/131987845