PTA 旅游规划

题目描述

有了一张自驾旅游路线图,你会知道城市间的高速公路长度、以及该公路要收取的过路费。现在需要你写一个程序,帮助前来咨询的游客找一条出发地和目的地之间的最短路径。如果有若干条路径都是最短的,那么需要输出最便宜的一条路径。

输入格式:

  输入说明:输入数据的第1行给出4个正整数N、M、S、D,其中N(2≤N≤500)是城市的个数,顺便假设城市的编号为0~(N−1);M是高速公路的条数;S是出发地的城市编号;D是目的地的城市编号。
  随后的M行中,每行给出一条高速公路的信息,分别是:城市1、城市2、高速公路长度、收费额,中间用空格分开,数字均为整数且不超过500。
输入保证解的存在。

输出格式:

在一行里输出路径的长度和收费总额,数字间以空格分隔,输出结尾不能有多余空格。

输入样例:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
结尾无空行

输出样例:

3 40

AC代码

扫描二维码关注公众号,回复: 13454756 查看本文章
#include <iostream>
#include <cstring>
using namespace std;

const int N = 510;
int g[N][N], C[N][N];
int dist[N], cost[N];
bool st[N];

int n, m, s, d;

void dijkstra()
{
    
    
    memset(dist, 0x3f, sizeof(dist));
    dist[s] = 0;
    cost[s] = 0;

    for (int i = 0; i < n; i ++)
    {
    
    
        int t = -1;
        for (int j = 0; j < n; j ++)
            if (st[j] == false && (t == -1 || dist[t] > dist[j])) t = j;
        st[t] = true;

        for (int j = 0; j < n; j ++)
            if (dist[j] > dist[t] + g[t][j] || (dist[j] == dist[t] + g[t][j] && cost[j] > cost[t] + C[t][j])) 
            {
    
    
                dist[j] = dist[t] + g[t][j];
                cost[j] = cost[t] + C[t][j];
            }
    }
}

int main()
{
    
    
    memset(g, 0x3f, sizeof(g));
    memset(C, 0x3f, sizeof(C));

    cin >> n >> m >> s >> d;
    while (m --)
    {
    
    
        int a, b, x, c;
        cin >> a >> b >> x >> c;
        g[b][a] = g[a][b] = min(g[a][b], x);
        C[b][a] = C[a][b] = min(C[a][b], c);
    }

    dijkstra();

    cout << dist[d] << ' ' << cost[d];
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Shao_yihao/article/details/121337994
PTA