HDU 4745-Two Rabbits(最长非连续回文串,区间DP)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=4745

Two Rabbits

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1767    Accepted Submission(s): 914


Problem Description
Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time. 

Now they want to find out the maximum turns they can play if they follow the optimal strategy.
 

Input
The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.
 

Output
For each test case, print a integer denoting the maximum turns.
 

Sample Input
  
   
   
1 1 4 1 1 2 1 6 2 1 1 2 1 3 0
 

Sample Output
  
   
   
1 4 5


//区间DP, 转换成求最长非连续的回文串
//将数组扩大为2倍,计算每个区间的最长非连续的回文串
//状态转移方程dp[i][j] = max(dp[i][j], dp[i+1][j], dp[i][j-1], a[i]==a[j]?a[i+1][j-1]+2:0)
//注意像字符串1221,计算出来的dp[0][3] = 4,而不是2
//所以最后结果肯定是只有n个字符,或者n-1的字符加个1
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 1005
#define inf 0x3f3f3f3f
using namespace std;

int a[maxn<<1];
int dp[maxn<<1][maxn<<1];          //dp[i][j] 表示区间[i,j]的最长非连续的回文串

int main()
{
	int n;
	while(scanf("%d", &n),n)
	{
		memset(dp, 0, sizeof(dp));
		for(int i=0; i<n; i++)
		{
			scanf("%d", &a[i]);
			a[n+i] = a[i];
		}
		//1个字符时,肯定是1了
		for(int i=0; i<2*n; i++)
			dp[i][i] = 1;
		for(int len=2; len<=2*n; len++)
			for(int i=0; i+len<2*n; i++)
			{
				int j = i+len-1;
				if(a[i]==a[j])
				{
					dp[i][j] = max(dp[i][j], dp[i+1][j-1]+2);
				}
				dp[i][j] = max(dp[i][j], max(dp[i+1][j], dp[i][j-1]));
			}
		int ans = 0;
		//n个字符
		for(int i=0; i<n; i++)
			ans = max(ans, dp[i][i+n-1]);
		//n-1个字符,最后一个当做公共的起点,所以+1
		for(int i=0; i<n; i++)
			ans = max(ans, dp[i][i+n-2]+1);
		printf("%d\n", ans);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_31281327/article/details/76576421