Two Rabbits HDU - 4745(最长回文子序列,区间dp)

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn’t jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time.

Now they want to find out the maximum turns they can play if they follow the optimal strategy.
Input
The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.
Output
For each test case, print a integer denoting the maximum turns.
Sample Input
1
1
4
1 1 2 1
6
2 1 1 2 1 3
0
Sample Output
1
4
5

Hint
For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2.
For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5.

题意:
一个环。 两个兔子单方向的跳(可以多格),但是自己的方向上不能超过以前的节点。并且要求每次所在节点的权值相同。要求最多可以跳多少轮。
思路:
本质就是最长回文子序列。只要两个兔子在回文子序列的对应节点上,就可以跳完整条链。
定义dp[i][j]为i到j的最长回文子序列。
答案为max{dp[1][i] + dp[i + 1][j]}。

也可以将链扩大一倍。答案就变成了
dp[i][i + n - 1]
dp[i][i + n - 2] + 1 (少了的那个点作为两只兔子的同时起点)

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int dp[2005][2005];
int a[2005];

int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&a[i]);
            dp[i][i] = dp[i + n][i + n] = 1;
            a[i + n] = a[i];
        }
        
        for(int len = 2;len <= 2 * n;len++)
        {
            for(int i = 1;i + len - 1 <= 2 * n;i++)
            {
                int j = i + len - 1;
                if(a[i] == a[j])dp[i][j] = dp[i + 1][j - 1] + 2;
                else dp[i][j] = max(dp[i + 1][j],dp[i][j - 1]);
            }
        }
        
        int ans = 0;
        for(int i = 1;i <= n;i++)
        {
            ans = max(ans,dp[i][i + n - 1]);
            ans = max(ans,dp[i][i + n - 2] + 1);
        }
        printf("%d\n",ans);
    }
    return 0;
}
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int dp[1005][1005];
int a[1005];

int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&a[i]);
            dp[i][i] = 1;
        }
        for(int len = 1;len <= n;len ++)
        {
            for(int i = 1,j = len;j <= n;i++,j++)
            {
                int x = 2;
                if(i == j)x = 1;
                
                if(a[i] == a[j])dp[i][j] = dp[i + 1][j - 1] + x;
                else dp[i][j] = max(dp[i][j - 1],dp[i + 1][j]);
            }
        }
        int ans = 0;
        for(int i = 1;i <= n;i++)
        {
            ans = max(dp[1][i] + dp[i + 1][n],ans);
        }
        printf("%d\n",ans);
    }
    return 0;
}
发布了676 篇原创文章 · 获赞 18 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/104230368
今日推荐