区间dp入门(HDU 4745 Two Rabbits)

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai. 

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise. 

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise. 

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone. 

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time. 

Now they want to find out the maximum turns they can play if they follow the optimal strategy.

Input

The input contains at most 20 test cases. 
For each test cases, the first line contains a integer n denoting the number of stones. 
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000) 
The input ends with n = 0.

Output

For each test case, print a integer denoting the maximum turns.

Sample Input

1
1
4
1 1 2 1
6
2 1 1 2 1 3
0

Sample Output

1
4
5

Hint

For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2.
For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5.

题意:两个兔子以相反的方向在一个环内跳,不能越过已经被自己跳过的石头,也就是求最大连续序列和,不过是一个环形的。

非环型dp公式为dp[i][j] = max{ dp[i + 1][j], d[i][j - 1], (if a[i] == a[j]) dp[i + 1][j - 1] + 2 }

在这个环形中,进行dp,最后的结果就是dp[1][i]+dp[i+1][n];

上图就会先求出dp[1][4]然后加上dp[5][6](0)为所求;

上图dp[1][j]+dp[j+1][n]即为所求;

上图dp[1][j]+dp[j+1][n]为所求,其中dp[1][i]事先求出;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<ctime>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 1001
#define MOD 10007
#define E 1e-6
#define LL long long
using namespace std;
int a[N];
int dp[N][N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            dp[i][i]=1;//初始化,单个字符一定是一个回文子串
        }
        for(int len=2;len<=n;len++)//枚举区间长度;
        {
            for(int i=1;i+len-1<=n;i++)//枚举起点
            {
                int j=i+len-1;//终点;-
                dp[i][j]=max(dp[i][j],max(dp[i+1][j],dp[i][j-1]));
                if(a[i]==a[j])
                    dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
            }
        }//可求出dp[1][i]的最大值;
        int cnt=0;
        for(int i=1;i<=n;i++)
            cnt=max(cnt,dp[1][i]+dp[i+1][n]);
        printf("%d\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/82290575