hdu 4745 (区间动态规划)

Two Rabbits

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2230    Accepted Submission(s): 1156


Problem Description
Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time. 

Now they want to find out the maximum turns they can play if they follow the optimal strategy.
 

Input
The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.
 

Output
For each test case, print a integer denoting the maximum turns.
 

Sample Input
 
  
1 1 4 1 1 2 1 6 2 1 1 2 1 3 0
 

Sample Output
 
  
1 4 5
Hint
For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2. For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5.

题解:转化为回文串,一条路是从区间[1,i]走到[i+1,n],另一条是反向从i->1,n->i+1;求两个区间的最长回文串。

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define rep(i,a,n) for(int i=(a);i<(n);++i)
#define per(i,a,n) for(int i=(n-1);i>=(a);--i)
#define INF 1e9
const int mod=1e9+7;
#define N 1010
int a[N];
int dp[N][N];
// 8 1 1 2 1 3 4 3 6
int main(){
    ios::sync_with_stdio(0);
    int n;
    while(scanf("%d",&n)&&n){
        for(int i=0;i<n;++i){
            scanf("%d",&a[i]);
        }
        for(int i=0;i<n;++i) dp[i][i]=1;  //区间长度为1
        for(int l=1;l<n;++l){     //区间长度从2开始,j-i+1
            for(int i=0;i+l<n;++i){   //区间左端点
                int j=i+l;           //区间右端点
                dp[i][j]=0;
                if(a[i]==a[j]){
                    dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
                }
                dp[i][j]=max(dp[i][j],dp[i][j-1]);
                dp[i][j]=max(dp[i][j],dp[i+1][j]);
            }
        }
        int ans=0;
        for(int k=0;k<n;++k){
            ans=max(ans,dp[0][k]+dp[k+1][n-1]);
        }
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u011721440/article/details/80266944