HDU4745-Two Rabbits(区间DP)

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn’t jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time.

Now they want to find out the maximum turns they can play if they follow the optimal strategy.
Input
The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.
Output
For each test case, print a integer denoting the maximum turns.
Sample Input
1
1
4
1 1 2 1
6
2 1 1 2 1 3
0
Sample Output
1
4
5

分析:

题意:
有两只兔子和n块排成一圈的石头,每块石头都有自己的质量,两只兔子各自选择一块石头开始向一个方向同时起跳,两只兔子可以同时站在一块石头上,两只兔子的方向相反,一只兔子一旦选定的一个方向就一直按照这个方向跳,要求两只兔子下方的石头的质量在任何时候都应该相等,兔子不能从已经跳过的上方跳过,也不能再跳到曾经站过的石头上,请问两只兔子最多能跳几次?

解析:
题意很明了,但是我不知道怎么解!于是看了题解,当看到回文时就知道怎么做了!毕竟做过不少这中回文题了!

dp[i][j]:记录从i~j块石头最多跳几次!
(1)如果str[i]==str[j]:dp[i][j]=dp[i+1][j-1]+2;(因为这两块对称的石头,两只兔子可以交换着站)
(2)如果str[i]!=str[j]:dp[i][j]=max(dp[i+1][j],dp[i][j-1]);

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 1005

using namespace std;

int dp[N][N];
int book[N];

int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&book[i]);
			dp[i][i]=1;
		}
		for(int len=2;len<=n-1;len++)
		{
			for(int i=1;len+i-1<=n;i++)
			{
				int j=len+i-1;
				if(book[i]==book[j])
					dp[i][j]=dp[i+1][j-1]+2;
				else
					dp[i][j]=max(dp[i+1][j],dp[i][j-1]);
			}
		}
		int Max=0;
		for(int i=1;i<=n;i++)
		{
			Max=max(dp[1][i]+dp[i+1][n],Max);
		}
		printf("%d\n",Max);
	}
	return 0;
 }

猜你喜欢

转载自blog.csdn.net/weixin_43357583/article/details/105844754
今日推荐