二分图+染色

There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print “No”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No
3
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn=205;
int n,m,flag;
int mp[maxn][maxn],vis[maxn],book[maxn],dis[maxn];
void dfs(int x,int clore)
{
    
    
	if(vis[x]==0)//没有被染色时
	vis[x]=clore;
	if(flag==1) return ;//不能用二分图表示,回溯
	for(int i=1;i<=n;i++)
	{
    
    
		if(mp[x][i]==1)//有关系
		{
    
    
			if(vis[i]==0)//没有被染色
			{
    
    
				vis[i]=-clore;//染色
				dfs(i,vis[i]);//搜索,判断是否构成了环
			}
			if(vis[i]==vis[x])//如果染色相同说明构成了环,结束
			{
    
    
				flag=1;
				return ;//回溯
			}
		}
	}
	return ;
}
bool hungry(int x)
{
    
    
	for(int i=1;i<=n;i++)
	{
    
    
		if(book[i]==0&&mp[x][i])
		{
    
    
			book[i]=1;
			if(dis[i]==-1||hungry(dis[i]))
			{
    
    
				dis[i]=x;
				return 1;
			}
		}
	}
	return false;
}
int main()
{
    
    
	while(~scanf("%d%d",&n,&m)&&(n+m))
	{
    
    
		flag=0;
		memset(mp,0,sizeof(mp)); 
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=m;i++)
		{
    
    
			int x,y;
			scanf("%d%d",&x,&y);
			mp[x][y]=mp[y][x]=1;
		}
		dfs(1,1);
		if(flag)
		{
    
    
			printf("No\n");
			continue;
		}
		else 
		{
    
    
			int ans=0;
			memset(dis,-1,sizeof(dis));
			for(int i=1;i<=n;i++)
			{
    
    
				memset(book,0,sizeof(book));
				if(hungry(i)) ans++;
			}
			printf("%d\n",ans/2);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/csx_zzh/article/details/115188275
今日推荐