HDU 5971(二分图染色2016 大连)

owadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".

Input

Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.

Output

If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".

Sample Input

5 4 0 0
1 3
1 4
3 5
4 5
5 4 1 0
1 3
1 4
3 5
4 5
2

Sample Output

NO
YES
#include<iostream>
#include<stdlib.h>  
#include<stdio.h>  
#include<cmath>  
#include<algorithm>  
#include<string>  
#include<string.h>  
#include<set>  
#include<queue>  
#include<stack>  
#include<vector>  
#include<map>  
using namespace std;
const int maxn = 25000 + 10;
int n, m, x, y;
vector<int>G[maxn];
int color[maxn];
void init() {
	memset(color, 0, sizeof(color));
	for (int i = 0; i < maxn; i++)
		G[i].clear();
}
 
int dfs(int s) {
	for (int i = 0; i < G[s].size(); i++) {
		int v = G[s][i];
		if (color[v] == 0) {
			color[v] = -color[s];
			if (!dfs(v))
				return 0;
		}
		else if (color[s] == color[v])
			return 0;
	}
	return 1;
}
 
int main() {
	while (scanf("%d%d%d%d",&n,&m,&x,&y)!=EOF){
		
		init();
		int a, b;
		for (int i = 0; i < m; i++) {
			scanf("%d%d", &a, &b);
			G[a].push_back(b);
			G[b].push_back(a);
		}
		for (int i = 0; i < x; i++) {
			scanf("%d", &a);
			color[a]=1;
		}
		for (int i=0;i<y;i++) {
			scanf("%d", &b);
			color[b] = -1;
		}
		if ((x == 0&&y == 0)||n==1){
			printf("NO\n");
			continue;
		}
		int ans = 1;
		for (int i = 1; i <= n; i++) {
			if (color[i]!=0 && dfs(i) == 0) {
				ans = 0;
				break;
			}
		}
		for (int i = 1; i <= n; i++) {
			if (color[i] == 0) {
				color[i] = 1;
				if (dfs(i) == 0) {
					ans = 0;
					break;
				}
			}
		}
		if (ans == 1)printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

https://blog.csdn.net/migu77777/article/details/71154149

猜你喜欢

转载自blog.csdn.net/qq_41453511/article/details/82109139
今日推荐