codeup|问题 C: Be Unique (20)

题目描述
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
输入
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.
输出
For each test case, print the winning number in a line. If there is no winner, print “None” instead.
样例输入 Copy
7 5 31 5 88 67 88 17
5 888 666 666 888 888
样例输出 Copy
31
None

代码

#include<stdio.h>

int main() {
    
    
    int n;
    int a[100000];
    int HashTable[100000] = {
    
    0};
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
    
    
        scanf("%d", &a[i]);
        HashTable[a[i]]++;
    }
    for (int i = 0; i < n; i++) {
    
    
        if (HashTable[a[i]] == 1) {
    
    
            printf("%d\n", a[i]);
            break;
        }
        if (i == n - 1 && HashTable[a[i]] != 1) {
    
    
            printf("None\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43340821/article/details/114368063
今日推荐