codeup|问题 C: To Fill or Not to Fill

题目描述
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入
Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,…N. All the numbers in a line are separated by a space.

输出
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print “The maximum travel distance = X” where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入 Copy
59 525 19 2
3.00 314
3.00 0
样例输出 Copy
82.89

提示
该题目所要解决的问题是:给定若干加油站信息,问能否驾驶汽车行驶一定的距离。如果能够行驶完全程,则计算最小花费。若不能行驶完全程,则最远能够行驶多长距离。

拿到这一题,首先判断汽车是否能够行驶到终点。什么情况下汽车无法行驶到终点呢?两种情况:起点根本就没有加油站,汽车无法启动;或者中途两个加油站之间的距离大于加满油后汽车能够行驶的最大距离。前者汽车行驶的最大距离为0.00,而后者最大距离为当前加油站的距离加上在这个加油站加满油后能够行驶的最大距离。在这里,需要将加油站按到杭州的距离从小到大排序。

接下来在能够行驶到终点的情况下计算最小花费。我们首先从路程来考虑,如果在路上,我们能够使用最便宜的汽油,当然就在那个加油站加油了。所以从起点开始遍历每个加油站。假设遍历到了第i个加油站,我们现在来判断在加油站i应该加多少油。设当前汽车离杭州的距离为curLen,当前加油站离杭州的距离为nodes[i].dis,加满油以后汽车能够行驶的最大距离为(dis=cmax*len)。这样就有node[i].dis <= curLen <= nodes[i].dis+dis,否则的话第i个加油站的油是不起作用的。于是在第i个加油站的作用范围内寻找有没有更为便宜的加油站,如果有,则下次使用这个加油站的油(j),这次汽车应该行驶到这个加油站,即touch=nodes[j].dis。如果没有找到更为便宜的加油站则可以在第i个加油站加满油,即touch=nodes[i].dis+dis。然后判断下次应该行驶到的距离与当前距离的关系,如果下次应当行驶到的距离大于当前距离,则汽车行驶,否则不动(也就是说上个加油站的油更便宜,后一个加油站也便宜,根本就不需要在当前加油站加油)。

代码

#include<iostream>
#include<algorithm>
#include<iomanip>
using namespace std;

class Station
{
    
    
public:
    int dis;
    float pri;
    Station()
    {
    
    
        dis = 0;
        pri = 0;
    }

};

bool cmp(Station a, Station b)
{
    
    
    return a.dis < b.dis;
}

Station s[501];
float res;//结果


int main()
{
    
    

    int cmax, d,  n, i, j;
    float davg;
    float maxDis;//加满一次行驶最大距离
    float res = 0;

    while(cin >> cmax)
    {
    
    
        res = 0;
        cin >> d >> davg >> n;
        maxDis = cmax * davg;
        for (i=0; i<n; i++)
        {
    
    
            cin >> s[i].pri >> s[i].dis;
        }
        s[n].dis = d;//去特殊化
        sort(s, s+n, cmp);
        if (s[0].dis != 0)
        {
    
    
            cout << "The maximum travel distance = 0.00" << endl;
            continue;
        }

        int curPos=0;
        float curOil=0;//当前距离、油箱剩油
        for (i=0; i<n ; i++)//每次一站
        {
    
    
            curPos = s[i].dis;
            //无法到达终点
            if (curPos + maxDis < s[i+1].dis)
            {
    
    
                cout << "The maximum travel distance = ";
                cout << setiosflags(ios::fixed) << setprecision(2) << curPos+maxDis +0.0<< endl;
                break;
            }
            //减掉中间行驶耗油
            if (i>0)
            {
    
    
                curOil = curOil - (s[i].dis - s[i-1].dis)/davg;
            }
            //如果最大距离内有较便宜
            int curDis = 0;
            bool isCheap = false;
            for (j=i+1; j<n; j++)
            {
    
    
                curDis = s[j].dis - s[i].dis;
                if (curDis>maxDis)//如果没有
                {
    
    
                    //res += (cmax - curOil)*s[i].pri;
                    //curOil = cmax;
                    break;
                }
                if (s[j].pri<s[i].pri)//有行驶到便宜站
                {
    
    
                    float temp = curOil;

                    curOil = (s[j].dis - s[i].dis )/davg;//应保证油量
                    if (temp - curOil < 0)
                    {
    
    
                        res += (curOil - temp)*s[i].pri;//补充加油
                    }
                    else
                    {
    
    
                        curOil = temp;//不需要加油
                    }
                    isCheap = true;
                    break;
                }
            }// end of for
            //最大距离内未找到便宜站
            if (!isCheap)
            {
    
    
                if (curPos+maxDis>=d)//到达终点
                {
    
    
                    res += ((d - curPos)/davg - curOil) *s[i].pri;
                    cout << setiosflags(ios::fixed) << setprecision(2);
                    cout << res << endl;

                    break;
                }
                else//未到终点,加满油
                {
    
    
                    res += (cmax - curOil)*s[i].pri;
                    curOil = cmax;
                }
            }
        }//end of for (每次一站)

    }//end of while
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43340821/article/details/114439495