L1-048矩阵A乘以B AC代码(JAVA)

题目

给定两个矩阵A和B,要求你计算它们的乘积矩阵AB。需要注意的是,只有规模匹配的矩阵才可以相乘。即若A有R​a 行、
Ca列,B有R​b​​行、C​b列,则只有C​a与Rb相等时,两个矩阵才能相乘。

输入格式:
输入先后给出两个矩阵A和B。对于每个矩阵,首先在一行中给出其行数R和列数C,随后R行,每行给出C个整数,以1个空格分隔,且行首尾没有多余的空格。输入保证两个矩阵的R和C都是正数,并且所有整数的绝对值不超过100。

输出格式:
若输入的两个矩阵的规模是匹配的,则按照输入的格式输出乘积矩阵AB,否则输出Error: Ca != Rb,其中Ca是A的列数,Rb是B的行数。

输入样例1:
2 3
1 2 3
4 5 6
3 4
7 8 9 0
-1 -2 -3 -4
5 6 7 8
输出样例1:
2 4
20 22 24 16
53 58 63 28
输入样例2:
3 2
38 26
43 -5
0 17
3 2
-11 57
99 68
81 72
输出样例2:
Error: 2 != 3

注意:用Scanner测试点3会超时错误,需要用BufferedReader流来读取数据
Scanner和BufferedReader性能的比较

AC代码:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Scanner;

public class Main {
    
    

	public static void main(String[] args) throws IOException {
    
    
		BufferedReader input = new BufferedReader(new InputStreamReader(System.in));
		//Scanner input2 = new Scanner(System.in);
		String [] lengths = input.readLine().split(" ");
		int ra = Integer.parseInt(lengths[0]);
		int ca = Integer.parseInt(lengths[1]);
		int A[][] = new int[ra][ca];
		for (int i = 0; i < ra; i++) {
    
    
			String datas[] = input.readLine().split(" ");
			for (int j = 0; j < ca; j++) {
    
    
				A[i][j] = Integer.parseInt(datas[j]);
			}
		}
		
		String [] len2 = input.readLine().split(" ");
		int rb = Integer.parseInt(len2[0]);
		int cb = Integer.parseInt(len2[1]);
		int B[][] = new int[rb][cb];
		for (int i = 0; i < rb; i++) {
    
    
			String datas[] = input.readLine().split(" ");
			for (int j = 0; j < cb; j++) {
    
    
				B[i][j] = Integer.parseInt(datas[j]);
			}
		}
		
		if (ca == rb) {
    
    
			int C[][] = new int[105][105];
			for (int i = 0; i < ra; i++) {
    
    
				for (int j = 0; j < cb; j++) {
    
    
					for (int k = 0; k < rb; k++) {
    
    
						C[i][j] += A[i][k] * B[k][j];
					}
				}
			}
			System.out.println(ra + " " + cb);
			for (int i = 0; i < ra; i++) {
    
    
				for (int j = 0; j < cb; j++) {
    
    
					if (j == cb - 1) {
    
    
						System.out.println(C[i][j]);
					} else {
    
    
						System.out.print(C[i][j] + " ");
					}
				}
			}
		} else {
    
    
			System.out.println("Error: " + ca + " != " + rb);
		}
		input.close();
	}
}

猜你喜欢

转载自blog.csdn.net/qq_45880043/article/details/108717649