PTA The Best Rank (25分)

释放无限光明的是人心,制造无边黑暗的也是人心,光明和黑暗交织着,厮杀着,这就是我们为之眷恋又万般无奈的人世间。

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#include<climits>//INT_MAX
//#include<bits/stdc++.h>
#define PP pair<ll,int>
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3fll
#define dinf 1000000000000.0
#define PI 3.1415926
typedef long long ll;
using namespace std;
int const mod=1e9+7;
const int maxn=2e3+10;
struct node {
    int id;
    int fs[4];
}a[maxn];
int jc[10000000][4];
int n,m,ct;
char c[4]={'A','C','M','E'};
bool comp(node x,node y)
{
    return x.fs[ct]>y.fs[ct];
}
int main()
{
    scanf("%d%d", &n, &m);
    for(int i=0; i<n; i++)
    {
        scanf("%d%d%d%d", &a[i].id, &a[i].fs[1], &a[i].fs[2], &a[i].fs[3]);
        a[i].fs[0]=a[i].fs[1]+a[i].fs[2]+a[i].fs[3];
        for(int j=0; j<4; j++)
            jc[a[i].id][j]=n+1;
    }
    for(ct=0;ct<4;ct++)
    {
        sort(a, a+n, comp);
        jc[a[0].id][ct]=1;
        for (int i=1; i<n; i++)
        {
            if(a[i].fs[ct]==a[i-1].fs[ct])
                jc[a[i].id][ct]=jc[a[i-1].id][ct];
            else
                jc[a[i].id][ct]=i+1;
        }
    }
    while(m--)
    {
        int x;
        scanf("%d", &x);
        if (jc[x][0]!=0)
        {
            int k=0;
            for (int i=0; i<4; i++)
            {
                if (jc[x][i]<jc[x][k])
                    k = i;
            }
            printf("%d %c\n", jc[x][k], c[k]);
        }
        else
            printf("N/A\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/108571569