PTA(Advanced Level)1012.The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A
思路
  • 要经过4次排序,每次都要记录结果,不然后面每次查询都排序应该会超时
  • 注意分数一样的时候的处理,比如5个人的得分分别是:92 92 90 85 85 ,对应的排名应该是1 1 3 4 4
代码
#include<bits/stdc++.h>
using namespace std;
struct student
{
    int id;
    int score[4];   //分别记录A、C、M、E的分数
}a[2100];
int n,m;
int ranking[10000010][4] = {0};   //学号对应的,按某一类来排名的结果
int pos;
char s[4][2] = {"A", "C", "M", "E"};

bool cmp(student x, student y)
{
    return x.score[pos] > y.score[pos];
}

int main()
{
    cin >> n >> m;
    for(int i=0;i<n;i++)
    {
        cin >> a[i].id;
        cin >> a[i].score[1] >> a[i].score[2] >> a[i].score[3];
        a[i].score[0] = (a[i].score[1] + a[i].score[2] + a[i].score[3]) / 3;
    }

    for(pos=0;pos<4;pos++)      //4次排序
    {
        sort(a, a+n, cmp);
        ranking[a[0].id][pos] = 1;      //第一个当然是第一了

        //比如5个人的得分分别是:92 92 90 85 85 ,对应的排名应该是1 1 3 4 4
        for(int i=1;i<n;i++)
        {
            if(a[i].score[pos] == a[i-1].score[pos])
                ranking[a[i].id][pos] = ranking[a[i-1].id][pos];
            else
                ranking[a[i].id][pos] = i + 1;
        }
    }
    int t;
    for(int i=0;i<m;i++)
    {
        cin >> t;
        if(ranking[t][0] == 0)
            cout << "N/A\n";
        else
        {
            int k = 0;
            for(int j=0;j<4;j++)
                if(ranking[t][j] < ranking[t][k])   k = j;
            cout << ranking[t][k] << " " << s[k] << endl;
        }
    }
    return 0;
}

引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805502658068480

猜你喜欢

转载自www.cnblogs.com/MartinLwx/p/11761916.html
今日推荐