HDU——1232 畅通工程(并查集的简单应用)模板题

畅通工程

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1232

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?


Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。


Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998

Huge input, scanf is recommended.


题意:给出城市数量和桥的数量以及桥连通这哪些城市,问最少还需要建多少座桥才能实现所有城市的连通。

解题思路:首先就应该想到是并查集,可怎么用呢?如果没有桥的话,根据无向连通图来说要n-1条边,即n-1座桥,那么假设一开始的城市都是独立的,通过数据我们来将他们合并起来,若合并成功,则所需建的桥数就减1.


AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<cstring>
#include<memory.h>
#include<map>
#include<iterator>
#include<list>
#include<set>
#include<functional>

using namespace std;

const int maxn=1005;//最大城镇数目
int father[maxn];//记录每个城市的连接者。
int n,m;//n代表城镇数,m代表道路数。
int temp1,temp2;//临时变量存储
int ans;//需要建设的最少道路数。
int Find(int x){
	//寻找最高级的城市。
	int r=x;
	while(father[r]!=r){
		r=father[r];
	}
	int i=x,j;
	while(father[i]!=r){
		j=father[i];
		father[i]=r;
		i=j;
	}
	return r;
}
void make_friend(int x,int y){ //x和y是表示已经建好的路,故我们这里是进行合并。
	int fx=Find(x),fy=Find(y);
	if(fx!=fy){
		//也就是不是直接相连的
		father[fx]=fy;
		ans--;
	}
}
int main(){
	while(cin>>n){
		if(n==0)break;
		cin>>m;
		ans=n-1;//设一开始认为他们都是独立的道路,那么要让他们都连接至少
		for(int i=1;i<maxn;i++)
			//是从1开始编号。
			father[i]=i;//初始化。
		for(int i=0;i<m;i++){
			cin>>temp1>>temp2;
			make_friend(temp1,temp2);
		}
		cout<<ans<<endl;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzf0701/article/details/107598252