kuangbin专题十四 数论基础(D - Sigma Function )(找规律)

D - Sigma Function

Sigma function is an interesting function in Number Theory. It is denoted by the Greek letter Sigma (σ). This function actually denotes the sum of all divisors of a number. For example σ(24) = 1+2+3+4+6+8+12+24=60. Sigma of small numbers is easy to find but for large numbers it is very difficult to find in a straight forward way. But mathematicians have discovered a formula to find sigma. If the prime power decomposition of an integer is

Then we can write,

For some n the value of σ(n) is odd and for others it is even. Given a value n, you will have to find how many integers from 1 to n have even value of σ.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1012).

Output

For each case, print the case number and the result.

Sample Input

4

3

10

100

1000

Sample Output

Case 1: 1

Case 2: 5

Case 3: 83

Case 4: 947

思路:弱弱的我这道题又看了别人的题解,发现这道题要找规律啊。(这么大的数似乎也只能找规律~)

具体规律大家可以看这位博主写的,很具体~
上代码(感觉这道题意义不大)
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    long long n;
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
    	scanf("%lld",&n);
    	long long a1=sqrt(n);
    	long long a2=sqrt(double(n/2));
    	printf("Case %d: %lld\n",i,n-a1-a2);
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/star_moon0309/article/details/79845531
今日推荐