kuangbin专题十四-数论基础-problem A(Bi-shoe and Phi-shoe )(简单欧拉定理)

A - Bi-shoe and Phi-shoe

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha


思路:好吧,承认这道题的确很水,其实就是裸的欧拉函数。稍微值得注意的是每一次查欧拉函数值与幸运值大小时,不要都从1开始循环,否则会TLE,应从幸运数开始循环,因为欧拉函数值不能大于这个数本身~
上代码:
#include<cstdio>
#include<cstring> 
using namespace std;
const int MAXN=1000010;
bool check[MAXN+10];
int phi[MAXN+10];
int prime[MAXN+10];
int tot;
void phi_and_prime(int N)
{
	memset(check,false,sizeof(check));
	phi[1]=0;
	tot=0;
	for(int i=2;i<=N;i++)
	{
		if(!check[i])
		{
			prime[tot++]=i;
			phi[i]=i-1;
		}
		for(int j=0;j<tot;j++)
		{
			if(i*prime[j]>N)
			{
				break;
			}
			check[i*prime[j]]=true;
			if(i%prime[j]==0)
			{
				phi[i*prime[j]]=phi[i]*prime[j];
				break;
			}
			else
			{
				phi[i*prime[j]]=phi[i]*(prime[j]-1);
			}
		}
	}
	return ;
}
int main()
{
	int t;
	int n;
	scanf("%d",&t);
	phi_and_prime(MAXN);
	long long sum;
	for(int i=0;i<t;i++)
	{
		scanf("%d",&n);
		sum=0;
		int tt;
		for(int j=0;j<n;j++)
		{
			scanf("%d",&tt);
			for(int l=tt;l<=MAXN;l++)
			{
				if(phi[l]>=tt)
				{
					sum+=l;
					break;
				}
			}
		}
        printf("Case %d: %lld Xukha\n",i+1,sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/star_moon0309/article/details/79842298