zoj 4070 Function and Function (找规律)

If we define , do you know what function  means?

Actually,  calculates the total number of enclosed areas produced by each digit in . The following table shows the number of enclosed areas produced by each digit:

Enclosed Area Digit Enclosed Area Digit
0 1 5 0
1 0 6 1
2 0 7 0
3 0 8 2
4 1 9 1

For example, , and .

We now define a recursive function  by the following equations:

For example, , and .

Given two integers  and , please calculate the value of .

Input

There are multiple test cases. The first line of the input contains an integer  (about ), indicating the number of test cases. For each test case:

The first and only line contains two integers  and  (). Positive integers are given without leading zeros, and zero is given with exactly one '0'.

Output

For each test case output one line containing one integer, indicating the value of .

Sample Input

6
123456789 1
888888888 1
888888888 2
888888888 999999999
98640 12345
1000000000 0

Sample Output

5
18
2
0
0
1000000000

这题找规律,到了后面就是0,1,循环。

#include <bits/stdc++.h>

using namespace std;
int a[10]={1,0,0,0,1,0,1,0,2,1};
int change(int x)
{
    int i,t=0;
    if(x==0)
        return a[x];
    while(x)
    {
        t=t+a[x%10];
        x=x/10;
    }
    return t;
}

int main()
{
   int t,x,k;
   scanf("%d",&t);
   while(t--)
   {
       scanf("%d %d",&x,&k);
       while(k)
       {
           k--;
           x=change(x);
           if(x==0)
            break;
       }
       if(k==0)
         printf("%d\n",x);
       else
       {
           if(k%2)
              printf("1\n");
           else
             printf("0\n");
       }

   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/intelligentgirl/article/details/84030771
今日推荐