hdu 1069 最长上升子序列和

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:有n种给了x,y,z的长方体,要求你用这些长方体叠出最大高度,要求上面的长方体的长和宽要严格小于下面的长方体。

这道题用dp来解决,给了x,y,z的长方体共有三种,那么最多的长方体不过是90种,题目给了n<=30,没必要去考虑时间复杂度的问题,那么我们把所有长方体存进结构体数组后,然后再按大小排序,然后开始dp

dp[i]表示前面i个长方体的最大高度,初始值为dp[i]=a[i].z,这个初始值很重要,没有就wa了,这个初始值代表的含义就是先假设我们最长上升子序列就是它自己,接着我们从0 -  i-1开始遍历, if(a[i].x>a[j].x&&a[i].y>a[j].y) 这个是最长上升子序列的条件,转移方程为 dp[i]=max(dp[j]+a[i].z,dp[i]),然后再一直更新最大值就可以了。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
struct node
{
    int x;
    int y;
    int z;
} a[10009];
node stack[10009];
int t;
int Count=1;
int dp[100009];
void init(int x,int y,int z)
{
    int i;
    for(i=0; i<=2; i++)
    {
        if(i==0)
        {
            a[t].x=min(z,y);
            a[t].y=max(z,y);
            a[t].z=x;
            t++;
        }
        else if(i==1)
        {
            a[t].x=min(x,z);//保证x一定最小
            a[t].y=max(x,z);
            a[t].z=y;
            t++;
        }
        else if(i==2)
        {
            a[t].x=min(x,y);//保证x一定最小
            a[t].y=max(x,y);
            a[t].z=z;
            t++;
        }
    }
}
int cmp(node a,node b)
{

    if(a.x==b.x) return a.y<b.y;
    else return a.x<b.x;
}
int main()
{
    int n,i,x,y,z,j;
    while(~scanf("%d",&n))
    {
        t=0;
        if(n==0) break;
        for(i=0; i<=n-1; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            init(x,y,z);
        }
        sort(a,a+t,cmp);
        int maxx=0;
        memset(dp,0,sizeof(dp));
        for(i=0; i<=t-1; i++)
        {
            dp[i]=a[i].z;
            for(j=0; j<=i-1; j++)
            {
                if(a[i].x>a[j].x&&a[i].y>a[j].y)
                {
                    dp[i]=max(dp[j]+a[i].z,dp[i]);
                }
            }
            maxx=max(dp[i],maxx);
           // printf("i==%d %d\n",i,dp[i]);
        }
        printf("Case %d: maximum height = %d\n",Count++,maxx);
    }
}

猜你喜欢

转载自blog.csdn.net/keepcoral/article/details/80094009