HDU-1160最长上升子序列

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20063    Accepted Submission(s): 8889
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input
 
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
 
  
4 4 5 9 7

题意:输入多组数据v,w,在v越大,w越小的情况下,最长的子序列多大,并输出所在的位置

思路:先对v排序,然后dp算出w的最长上升子序列,用一个数组记录i之前的小的位置,最后一并输出

坑点:无

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
    int v,w;
    int i;
}num[1100];
int dp[1100],ans[1100];
bool cmp(const node &a,const node &b)          //速度从大到小,重量从小到大 
{
    if (a.v!=b.v)
        return b.v<a.v;
    else 
        return a.w<b.w;
}
void print(int x)
{
    if (x==0)
        return ;
    print(ans[x]);
    cout<<num[x].i<<endl;
}
int main()
{
    int n,i,j,k,sum;
    i=1;
    memset(num,0,sizeof(num));
    while (cin>>num[i].w>>num[i].v)
        {
            num[i].i=i;
            i++;
        }
    sort(num+1,num+i+1,cmp);
    n=i-1;
    int Max;sum=0;
    for (i=1;i<=n;i++)
        {
            dp[i]=1;
            Max=0;
            for (j=i-1;j>=1;j--)        //找到i之前小的那位 
                if (num[i].w>num[j].w)
                    if (Max<dp[j])            //长度最大 
                        {
                            k=j;
                            Max=dp[j];
                        }
            if (Max!=0)                    //找到了,更新dp和ans 
                if (dp[k]+1>dp[i])
                    {
                        dp[i]=dp[k]+1;
                        ans[i]=k;            //表示i之前的小的位置 
                    }
            sum=max(sum,dp[i]);                //最长 
        }
    cout<<sum<<endl;
    for (i=1;i<=n;i++)
        if (dp[i]==sum)
            {
                print(i);
                break;
            }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/z1164754004z/article/details/81050208