HDU 1069 Monkey and Banana ---DP之最长上升子序列

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19410    Accepted Submission(s): 10317

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题解:这道题其实就和普通的DP问题求最长上升子序列差不多,但是这道题还多一个过程就是排序,先排好序再求最高的高度会比较方便,每一类型的积木都有6中摆放方法,将其一一列举出来存入动态数组中,然后直接套用最长上升子序列的模板即可。

#include <iostream>
#include <vector>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
    int x,y,z;
    bool operator<(const node& a)const
    {
        if(a.x==x)return y<a.y;
        else return x<a.x;
    }
    node(int xi,int yi,int zi):x(xi),y(yi),z(zi){}
};
vector<node>Q;
int main()
{
    int n,x,y,z,cont=0;
    int dp[100000];
    while(scanf("%d",&n),n)
    {
        Q.clear();

        for(int i=0;i<n;i++)
        {
            scanf("%d %d %d",&x,&y,&z);
            Q.push_back(node(x,y,z));
            Q.push_back(node(x,z,y));
            Q.push_back(node(y,x,z));
            Q.push_back(node(y,z,x));
            Q.push_back(node(z,x,y));
            Q.push_back(node(z,y,x));
        }
        sort(Q.begin(),Q.end());
        int length=Q.size();
        for(int i=0;i<length;i++)
            dp[i]=Q[i].z;
        int ans=0;
        for(int i=1;i<length;i++)
            for(int j=0;j<i;j++)
                if(Q[j].x<Q[i].x&&Q[j].y<Q[i].y)
                dp[i]=max(dp[i],dp[j]+Q[i].z);
            for(int i=0;i<length;i++)
                ans=max(ans,dp[i]);
        printf("Case %d: maximum height = %d\n",++cont,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_41233888/article/details/81215125