HDU-1069 Monkey and Banana [DP -> 二维最长上升串]

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
InputThe input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:给出n终立方体,长宽高可以由x,y,z自由组合,要求搭建最高的由这些立方体构成的塔,规定塔必需按每层立方体的长宽严格递减。

省赛前夕DP练习题,LIS的二维应用,详见代码。

Code:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
#include <algorithm>
using namespace std;
const int maxn=200;
int n;
int temp[100];
struct block{
    int x,y,h;
    block(){}
    block(int x,int y,int h):x(x),y(y),h(h){}
}B[maxn];
int dp[maxn];
int cmp(block a,block b){
    return a.x>b.x ||((a.x==b.x)&&(a.y>b.y));
}
int ans;
int cas=0;
int main(){
    while(scanf("%d",&n)==1 && n){
        
    int a,b,c;
        int k=1;
    for(int i=1;i<=n;i++){
        scanf("%d %d %d",&a,&b,&c);//一个立方体最多有6种组合方式。
        B[k++]=block(a,b,c);
        B[k++]=block(b,a,c);
        B[k++]=block(b,c,a);
        B[k++]=block(c,b,a);
        B[k++]=block(a,c,b);
        B[k++]=block(c,a,b);
    }
        sort(B+1,B+6*n+1,cmp);//按主长副宽递减排序
        memset(dp, 0, sizeof dp);
        for(int i=1;i<=6*n;i++)dp[i]=B[i].h;//初始状态赋值
        int ans=dp[6*n];
        for(int i=6*n-1;i>=1;i--){
            for(int j=i+1;j<=n*6;j++){
                if(B[i].x>B[j].x && B[i].y>B[j].y) dp[i]=max(dp[j]+B[i].h,dp[i]);
                }
            ans=max(ans,dp[i]);//答案要从每一个状态中去找
            }
            printf("Case %d: maximum height = %d\n",++cas,ans);
        }
    
}

猜你喜欢

转载自blog.csdn.net/qq_39665840/article/details/80140698