【HDU - 1069】Monkey and Banana (最长下降子序列 + 贪心,最长上升子序列类问题)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/81674858

题干:

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:

把给定的长方体(不限)叠加在一起,叠加的条件是,上面一个长方体的长和宽都比下面长方体的长

扫描二维码关注公众号,回复: 4625634 查看本文章

和宽短;求这些长方体能叠加的最高的高度.(其中(3,2,1)可以摆放成(3,1,2)、(2,1,3)等).

PS:

每块积木最多有 3 个不同的底面和高度,我们可以把每块积木看成三个不同的积木,

那么n种类型的积木就转化为3 * n个不同的积木,对这3 * n个积木的长按照从大到小排序;

然后找到一个递减的子序列,使得子序列的高度和最大。

解题报告:

     不懂为什么要按照长度排序。

AC代码:

#include<bits/stdc++.h>

using namespace std;

struct Node {
	int sm,bg,h;//小,大
	Node(){}
	Node(int sm,int bg,int h):sm(sm),bg(bg),h(h){}
	
} node[300000 + 5];
int dp[300000 + 5];
int top;
int n;

//bool cmp(Node a,Node b) {
//	if(a.bg > b.bg) return a.sm > b.sm;
//	else if(a.bg == b.bg) return a.sm > b.sm;
//	return 0;//即  b一定排在a前面了 
//}
bool cmp(Node a,Node b) {
	if(a.bg == b.bg) return a.sm > b.sm;
	else return a.bg > b.bg;
}
int main()
{
	int l,w,h;//长宽高 
	int iCase = 0;
	while(scanf("%d",&n)) {
		if(n == 0 ) break;
		top = 0;
		memset(dp,0,sizeof(dp));
		for(int i = 1; i<=n; i++) {
			scanf("%d%d%d",&l,&w,&h);
			if(l>w) node[++top] =Node(w,l,h);
			else   node[++top] =Node(l,w,h);
			if(l<h) node[++top] = Node(l,h,w);
			else node[++top] = Node(h,l,w);
			if(w<h) node[++top] = Node(w,h,l);
			else node[++top] = Node(h,w,l);
		}
		
		sort(node+1,node+top+1,cmp);
//		for(int i = 1; i<=top; i++) {
//			printf("%d  %d  %d\n",node[i].sm,node[i].bg,node[i].h);
//		}
//		printf("\n");
		for(int i = 1; i<=top; i++) dp[i] = node[i].h;
		for(int i = 1; i<=top; i++) {
			for(int j = 1; j<=i; j++) {
				if(node[i].bg < node[j].bg && node[i].sm < node[j].sm) {
					dp[i] = max(dp[i],dp[j] + node[i].h);
				}
			}
		}
		printf("Case %d: maximum height = %d\n",++iCase,*max_element(dp+1,dp+top+1));
	
	}
	
	
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/81674858