HDU5532 最长上升子序列 nlogn LIS

HDU5532 最长上升子序列 nlogn LIS

                                      Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 9995 Accepted Submission(s): 2336

Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an, is it almost sorted?

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,…,an.

1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000.

Output
For each test case, please output “YES” if it is almost sorted. Otherwise, output “NO” (both without quotes).

Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

Sample Output
YES
YES
NO

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

题目大意:就是问在给的原数列里拿掉一个数,问剩下的数是否可以看做有序。多组询问,每次询问多达1e5,用传统n^2会超时,所以用贪心二分优化(不太懂的可以先找篇博客看一下,简单来说就是对于每个在原序列的数字,替换不同长度的有序列的最后一位,达到贪心的目的)。

AC code:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
const int inf = 99999999;
int a[maxn];
int d[maxn];
int n;
int up()  //上升判断
{
    int top = 0;
    for(int i = 1; i<=n; i++)
        d[i] = inf;
    for(int i=0; i<n; i++)
    {
        int c = upper_bound(d+1,d+n+1,a[i])-d;  //因为排序不一定严格递增减,所以用upper
        d[c] = a[i];
        if(c>top)
            top = c;
    }
    return top;
}

int down()   //下降判断
{
    int top = 0;
    for(int i = 1; i<=n; i++)
        d[i] = inf;
    for(int i=0; i<n; i++)
    {
        int c = upper_bound(d+1,d+n+1,-a[i])-d;  //将d[i]取相反数,得到下降排列(或者可以将原列倒置)
        d[c] = -a[i];
        if(c>top)
            top = c;
    }
    return top;
}

int main ()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        if(up()>=n-1 || down()>=n-1)
            printf("YES\n");
        else
            printf("NO\n");

    }
    return 0;
}

发布了22 篇原创文章 · 获赞 4 · 访问量 547

猜你喜欢

转载自blog.csdn.net/yp0413170331/article/details/97257944