PAT A+B for Polynomials

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

#include <iostream>
#include<stdio.h>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
map<int,double> mmap;
bool cmp(const pair<int,double> p1,const pair<int,double> p2){
    return p1.first>p2.first;
}
int main(){
    //freopen("3.txt","r",stdin);
    int a;
    scanf("%d",&a);
    int n;
    double an;
    for(int i=0;i<a;i++){
        scanf("%d%lf",&n,&an);
        mmap[n]=an;
    }
    scanf("%d",&a);
    for(int i=0;i<a;i++){
        scanf("%d%lf",&n,&an);
        if(mmap.count(n)==0)
            mmap[n]=an;
        else
            mmap[n]+=an;
    }
    //直接输出size不对,因为有可能相加之后系数为0.0
    n=0;
    vector<pair<int ,double>> vp;
    for(map<int ,double>::iterator cur=mmap.begin();cur!=mmap.end();cur++)
    {
        if(cur->second!=0&&cur->second!=-0)//需要判断,是否相加后系数为0
            vp.push_back(make_pair(cur->first,cur->second));
    }
    sort(vp.begin(),vp.end(),cmp);
    printf("%d",vp.size());
    for(size_t i=0;i<vp.size();i++)
        printf(" %d %0.1f",vp[i].first,vp[i].second);
	return 0;
}


猜你喜欢

转载自blog.csdn.net/huanting74/article/details/80050600