PAT A 1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are twopolynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, andeach line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~... NK a~NK~, where K is the number of nonzero terms in the polynomial,Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients,respectively. It is given that 1 <= K <= 10,0 <= NK < ...< N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line,with the same format as the input. Notice that there must be NO extraspace at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
#include<cstdio>
int main() {
	int k, e, i;
	double c;
	double p[1010] = { 0 };        //系数存在p数组中

	scanf("%d", &k);        //输入两组数据
	for (i = 0; i < k; i++) {
		scanf("%d %lf", &e, &c);
		p[e] += c;
	}

	scanf("%d", &k);
	for (i = 0; i < k; i++) {
		scanf("%d %lf", &e, &c);
		p[e] += c;
	}

	int count = 0;
	for (i = 0; i <= 1000; i++) {
		if (p[i])count++;
	}

	printf("%d", count);
	for (i = 1000; i >= 0; i--) {
		if (p[i])printf(" %d %.1f", i, p[i]);        //前面已经输出了count,所以在每组前加个空格就行
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80536572