PAT-1002 A+B for Polynomials

版权声明:IT交流QQ群328880248,欢迎大家来一起学习一起交流~本篇文章未经同意请勿转载! https://blog.csdn.net/m0_38072683/article/details/89116415

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

思路 

用map写的第二个例子错误,这几天再研究研究

AC代码

#include<cstdio>
#include<algorithm>

using namespace std;

const int maxn = 1000 + 10;
double a[maxn];

int main(){
    int n1,k,maxx = 0;
    double n2;
    for(int i = 0; i < 2; i++) {
        scanf("%d", &k);
        for (int j = 0; j < k; j++) {
            scanf("%d %lf",&n1,&n2);
            maxx = max(maxx, n1);
            a[n1] += n2;
        }
    }
    int res = 0;
    for (int i = maxx; i >= 0; i--) {
        if(a[i] != 0)res++;
    }
    printf("%d", res);
    for (int i = maxx; i >= 0; i--) {
        if(a[i] != 0)printf(" %d %.1lf",i,a[i]);
    }
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_38072683/article/details/89116415