PAT(甲级)1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目大意:输入两个多项式,合并再输出,比较简单 ,为非就是在数组里面加加减减

#include<iostream>
#include<algorithm>

using namespace std;
float a[10000] = {0.0};
int main()
{
    int n;
    cin >> n;
    int cnt = 0;
    for (int i = 0; i < n;i++)
    {
        int b;
        float c;
        cin >> b >> c;
        a[b] += c;
    }
    cin >> n;
    for (int i = 0; i < n;i++)
    {
        int b;
        float c;
        cin >> b >> c;
        a[b] += c;
    }
//=============判断有多少个数的系数不是0==================//
     for (int i = 0; i < 10000;i++)
    {
        if(a[i] != 0)
            cnt++;
    }

    cout << cnt;
    for (int i = 9999; i >= 0;i--)
    {
        if(a[i] != 0)
        {
            cnt--;
            printf(" %d %0.1f", i, a[i]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35601980/article/details/88652794