HDU -> acm -> Humble Numbers

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
 
  
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
 

Sample Output
 
  




Sample Output
 
    
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 5843;
int humber[maxn];

void prepare() {
    int i;
    humber[1] = 1;
    int na;
    int nb;
    int nc;
    int nd;
    int pos1 = 1;
    int pos2 = 1;
    int pos3 = 1;
    int pos4 = 1;

    for (i = 2; i <= maxn; ++i) {
        //从符合要求的数中找到最小的那个数作为目前humber数
        humber[i] = min(min(na = humber[pos1] * 2,nb = humber[pos2] * 3),
                        min(nc = humber[pos3] * 5, nd = humber[pos4] * 7));

        if (humber[i] == na) {//如果选择了这个因子,则将起索引向后移一位
            pos1++;
        }
        if (humber[i] == nb) {
            pos2++;
        }
        if (humber[i] == nc) {
            pos3++;
        }
        if(humber[i] == nd){
            pos4++;
        }

    }
}

int main() {
    prepare();
    int n;
    while (scanf("%d", &n) != EOF, n) {
         printf("The %d",n);

        if (n % 100 != 11 && n % 10 == 1){
            printf("st");
        }else if (n % 100 != 12 && n % 10 == 2){
            printf("nd");
        }else if (n % 100 != 13 && n % 10 == 3){
            printf("rd");
        }else{
            printf("th");
        }
        printf(" humble number is %d.\n",humber[n]);
    }

    return 0;
}

 
 

猜你喜欢

转载自blog.csdn.net/desporado/article/details/80173265