hdoj1058:Humble Numbers(dp基础题+技巧筛法)

版权声明:转载请注明出处哦~ https://blog.csdn.net/Cassie_zkq/article/details/82926611

目录

Humble Numbers

解题思路:

ac代码:


Humble Numbers

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 17   Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

Input

扫描二维码关注公众号,回复: 3594778 查看本文章

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

解题思路:


1)筛法(详见代码1,标准模版)

2)for循环一次遍历(不推荐,见代码2),模拟一样就懂了

注意输出格式的问题

ac代码:


代码1

#include <iostream>
#include <cmath>
#include <algorithm>
#include <queue>
#include <cstring>
#define ll long long int
#define maxn 5890
using namespace std;
int main()
{
    ll a[maxn];
    int i,n;
    int f2=1,f3=1,f5=1,f7=1;
    a[1]=1;
    for(i=2;i<=maxn;i++)
    {
        a[i]=min(a[f2]*2,min(a[f3]*3,min(a[f5]*5,a[f7]*7)));
        if(a[i]==a[f2]*2) f2++;
        if(a[i]==a[f3]*3) f3++;
        if(a[i]==a[f5]*5) f5++;
        if(a[i]==a[f7]*7) f7++;
    }
    while(scanf("%d",&n),n)
    {
        if(n==0) break;
        printf("The %d",n);
        if(n%10==1 && n%100!=11) printf("st");
        else if(n%10==2 && n%100!=12) printf("nd");
        else if(n%10==3 && n%100!=13) printf("rd");
        else printf("th");
        printf(" humble number is %lld.\n",a[n]);
    }
    return 0;

}

代码2

#include <iostream>
using namespace std;

int main()
{
    unsigned long long humbleNums[5842] = { 0 };
    humbleNums[0] = 1;
    int prime[4] = { 2, 3, 5, 7 };
    for (unsigned long long i = 1; i < 5842; ++i)
    {
        humbleNums[i] = 20000000001;
        for (int j = 0; j < 4; ++j)
        {
            for (int k = i - 1; k >= 0;k--)
            {
                if (humbleNums[k]*prime[j]<=humbleNums[i-1])
                {
                    break;
                }
                if (humbleNums[k]*prime[j]<humbleNums[i])
                {
                    humbleNums[i] = humbleNums[k] * prime[j];
                }
            }
        }
    }
    int n;
    while (cin >> n)
    {
        if (n == 0)
        {
            break;
        }
        cout << "The " << n;
        if (n % 10 == 1 && n % 100 != 11)cout << "st ";
        else if (n % 10 == 2 && n % 100 != 12)cout << "nd ";
        else if (n % 10 == 3 && n % 100 != 13)cout << "rd ";
        else  cout << "th ";
        cout << "humble number is " << humbleNums[n-1] << "." << endl;

    }

    return 0;
}

---------------------

本文来自 alw_123 的CSDN 博客 ,全文地址请点击:https://blog.csdn.net/alw_123/article/details/51674140?utm_source=copy 

猜你喜欢

转载自blog.csdn.net/Cassie_zkq/article/details/82926611
今日推荐